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Jurassic Park (1993)
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How to Composite Virtual and Real?

• In the real world, we use a camera to record the 
information of the real scene

• In a virtual world, we use a virtual camera to record the 
information of the virtual scene

• Idea: make the virtual camera sync with the real-world 
camera and put the virtual objects in the right places
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How to Composite Virtual and Real? (cont.)
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Matchmove (Structure from Motion)

• Structure from Motion: automatic recovery of camera 
motion and scene structure from two or more images

• Also called matchmove in film production
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Matchmove (Structure from Motion)

• Structure from Motion: automatic recovery of camera 
motion and scene structure from two or more images

• Also called matchmove in film production
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feature



Features

• Also known as interesting points, salient points, or 
keypoints

• Points that you can easily point out their correspondences
in multiple images using only local information
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Desired Properties for Features

• Distinctive
• A single feature can be correctly matched with high 

probability

• Invariant
• Invariant to scale, rotation, illumination and noise for robust 

matching across a substantial range of distortion, viewpoint 
change and so on
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Applications

• Object or scene recognition

• Matchmove (structure from motion)

• Stereo

• Motion tracking

• …
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Components

• Feature detection locates where they are

• Feature description describes what they are

• Feature matching decides whether two are the same one
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Moravec Corner Detector

• We should easily recognize the point by looking 
through a small window

• Shifting a window in any direction should give a large 
change in intensity
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Moravec Corner Detector (cont.)
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flat



Moravec Corner Detector (cont.)
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flat



Moravec Corner Detector (cont.)
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flat edge



Moravec Corner Detector (cont.)
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flat edge
corner

isolated point



Moravec Corner Detector (cont.)

• Change of intensity for the shift [u, v]
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intensity

Four shifts: (u,v) = (1,0), (1,1), (0,1), (-1, 1)
Look for local maxima in min{E}



Problems of Moravec Detector

• Noisy response due to a binary window function

• Only a set of shifts at every 45 degree is considered

• Only minimum of E is taken into account
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➔ Harris corner detector solves these problems



Harris Corner Detector

• Noisy response due to a binary window function
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➔ Use a Gaussian function



Harris Corner Detector (cont.)

• Only a set of shifts at every 45 degree is considered
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➔ Consider all small shifts by Taylor’s expansion
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We can obtain a new measurement by 
investigating the shape of the error function



Harris Corner Detector (cont.)

• High-level idea: what shape of the error function will 
we prefer for features?
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Harris Corner Detector (Input)
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Harris Corner Detector (Response)
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Harris Corner Detector (Theshold)
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Harris Corner Detector (Local Maximum)
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Harris Corner Detector (Output)
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Feature Description

• Now we know where the features are

• But how to match them?

• What is the descriptor for a feature? The simplest 
solution is the intensities of its spatial neighbors 

• This might not be robust to brightness change or small 
shift/rotation
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Problems of Harris Detector

• Not invariant to image scale
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All points will be 
classified as edges

Corner !



Problems of Harris Detector (cont.)

• Not invariant to image scale
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SIFT

• Stands for Scaled Invariant Feature Transform

• For scale invariance, search for stable features across 
all possible scales using a continuous function of 
scale, scale space.
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Tracking
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feature

• If we detect a feature point in one frame, how do we 
keep tracks of it in other frames?



Tracking (cont.)
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Three Assumptions of Tracking

• Brightness consistency

• Spatial coherence 

• Temporal persistence
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Brightness Consistency

• Image measurement (e.g. brightness) in a small region 
remain the same although their location may change
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Spatial Coherence

• Neighboring points in the scene typically belong to the 
same surface and hence typically have similar motions. 

• Since they also project to nearby pixels in the image, 
we expect spatial coherence in image flow.
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Temporal Persistence

• The image motion of a surface patch changes 
gradually over time
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Simple Tracking Approach

• Minimize brightness difference

• For each offset (u, v) compute E(u, v)

• Choose (u, v) which minimizes E(u, v)

• Problems:
• Not efficient

• Only sub-pixel accuracy
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There are more efficient algorithms (e.g. Lucas-Kanade) 
for tracking



Back to the Matchmove Problem
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unknown
camera

viewpoints

We need to reconstruct the camera path
We also need to reconstruct the (partial) scene geometry



Back to the Matchmove Problem (cont.)

• For the scene geometry, we only recover the 3D 
position of feature points
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feature



Matchmove Pipeline
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2D feature
tracking

3D estimation
optimization

(bundle adjust)
geometry 

fitting



2D Feature Tracking
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• Detect good features (e.g. by SIFT)

• Find correspondences between frames



3D Estimation
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• Use 2 or 3 views at a time 

• Solve an optimization problem



Optimization
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• Iterative refine estimates



Geometry Fitting
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• Recover surface by image-based triangulation, 
silhouettes, or stereo

Good mesh



Matchmove in Blender
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Steps
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• Prepare a video

• Extract image sequence (optional)

• 3D estimation: solve and optimize camera motion and 
scene geometry

• Import 3D models and edit their animations

• Output video



Prepare a Video
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Prepare a Video

47

Multimedia Techniques and Applications 2022

• You can either capture your video (suggested) or 
download ones from the internet

• Some useful tips
• It is better to have many features in your video

• And the features should exist in the entire video (especially for 
the ground)

• Not too long (if it is, subdivide it and edit each part separately)

• Your camera should have both translation and rotation

• Your video should have large parallax 
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Bad example
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Good example



Extract Image Sequence (Optional)
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Convert a Video into Image Sequence
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• Why?
• Video files have compression built-in

• Using image sequence leads to better run-time performance
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Delete unused objects
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Load Your Video (1)

Change to ‘Movie Clip Editor’ 
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Load Your Video (2)

1. Make sure you choose the ‘Clip’ type

2. Press the ‘Open’ button
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Load Your Video (3)

1. Move to the folder you save the video

2. Double click the video to select it 
(or press the ‘Open Clip’ button)
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Load Your Video (4)

1. You will see your video is loaded

3. Press the ‘Set Scene Frames’ button
(set the video length)

2. Switch to the ‘Output’ panel
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Load Your Video (5)

You will see the number of frames has been changed
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Generate Image Sequence (1)

Change to ‘Compositor’ 
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Generate Image Sequence (2)

1. Check ‘Use Nodes’

2. Delete the default nodes

3. Tick the ‘Backdrop’ button
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Generate Image Sequence (3)

Add input node by choosing
‘Add’ ➔ ‘Input’ ➔ ‘Movie Clip’
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Generate Image Sequence (4)

Load your video
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Generate Image Sequence (5)

Add input node by choosing
‘Add’ ➔ ‘Output’ ➔ ‘Composite’
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Generate Image Sequence (6)

Add input node by choosing
‘Add’ ➔ ‘Output’ ➔ ‘Viewer’



64

Multimedia Techniques and Applications 2022

Generate Image Sequence (7)

Link ‘Image’ (Movie Clip) to ‘Image’ (Composite) and
Link ‘Image’ (Movie Clip) to ‘Image’ (Viewer)

You will see your video shown in the background
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Generate Image Sequence (8)

1. Set the folder to store the image sequence

2. Make sure the output type is ‘PNG’

3. Press ‘Render’ ➔ ‘Render Animation’
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Generate Image Sequence (9)

You will see your image sequence is rendering

And you can find your 
image files in the folder
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Close your Blender and Reopen It

Again, delete the unused objects



3D Estimation
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Load the Image Sequence (1)

Change to ‘Movie Clip Editor’ 
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Load the Image Sequence (2)

1. Make sure you choose the ‘Clip’ type

2. Press the ‘Open’ button
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Load the Image Sequence (3)

1. Move to the folder you save your 
image sequence

2. Press ‘a’ to select all image files

3. Press the ‘Open Clip’ button
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Or Load Your Video (If you skip step 1)

1. Move to the folder you save the video

2. Double click the video to select it 
(or press the ‘Open Clip’ button)
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Set Input Data (1)

2. Press the ‘Set Scene Frames’ button
(set the images/video length)

1. Switch to the ‘Output’ panel
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Set Input Data (2)

Press the ‘Prefetch’ button
(load the entire images/video into memory)

You will notice the color of the frame bar become lighter
(If your video is too large, you may fail to load the entire video into memory)
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Feature Detection (1)

Change the Motion model to ‘LocRotScale’
(you can also try ‘Affine’ or ‘Perspective’)
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Feature Detection (2)

2. Find a feature point in the scene

3. Press ‘Ctrl’ and ‘left click’ to add a feature
(You can scroll your middle mouse button to enlarge the view)

1. Make sure you are at the first frame
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Feature Detection (3)

Press ‘Track Markers (forward)’
because we are at the first frame
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Feature Detection (4)

Drag the timeline to ensure the feature is tracked correctly for all frames
The feature (center of the square) should stick to the same scene point
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Feature Detection (5)

According to the algorithm of Matchmove,
we need at least 8 feature points to solve the camera motion
(repeat the above steps until you have at least 8 features)
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Feature Detection (6)

You can also start at the last frame and 
press ‘Track Markers (backward)’
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Feature Detection (7)

Sometimes your tracking will fail in the middle frame
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Feature Detection (8)

Just go back to the frame with the correct tracking
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Feature Detection (9)

You can press ‘Alt’ + ‘s’ for showing the search range
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Feature Detection (10)

Press ‘s’ to scale the feature pattern size and search size
Adjust them to improve the uniqueness of the feature point
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Feature Detection (11)

Press ‘Track Markers (forward)’ again
It might work
(If it is not, repeat the last step and keep trying)
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Feature Detection (12)

Sometimes you will find your feature floating to another position
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Feature Detection (13)

1. Just go back to the last frame with correct tracking

2. First press ‘Clear Track Path (Forward)’ to clear tracking data (important!)
If you are tracking backward, press ‘Clear Track Path (Backward)’ instead 

3. You will find the green color (tracking) disappear
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Feature Detection (14)

Press ‘Track Markers (forward)’ again
It might work
(If it is not, repeat the last step and keep trying)
(If it keeps failing, delete the feature and choose another one)
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Feature Detection (15)

You can also try the automatic “Feature Detection” 
of Blender by pressing the ‘Detect Features’ button
(but in my experience, it is not faster)
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Feature Detection (16)

Once we have more than 8 tracked feature points, we 
are ready for camera estimation
Also, keep at least 3 points on the ground (important!)
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Setting Camera Parameters (1)

1. Switch to ‘Track’ panel

2. Type in the sensor width 
information of your camera



Camera Parameters
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• How do we know the camera parameters?
• Google it on the internet

• https://www.photocounter.com.au/wp-
content/uploads/2013/01/sensor-size-table.pdf

• You can also use Blender’s preset

https://www.photocounter.com.au/wp-content/uploads/2013/01/sensor-size-table.pdf
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Setting Camera Parameters (2)
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Solving Camera Motion (1)

2. Make sure all features are selected

1. Make sure you are at the first frame

3. Switch to ‘Solve’ panel

4. Tick Keyframe

6. Press ‘Solve Camera Motion’

5. Change ‘Refine’ to ‘Focal Length, K1, K2’
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Solving Camera Motion (2)

You will see the error here
It is suggest to have an error lower than 1
(better to have one lower than 0.5)
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Solving Camera Motion (3)

To know which feature works bad, 
show the info of each feature
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Solving Camera Motion (4)

Select and delete (right click) the feature 
with large error
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Solving Camera Motion (5)

Select all features and press ‘Solve Camera Motion’ again,
You may see the error drops



99

Multimedia Techniques and Applications 2022

Solving Camera Motion (6)

You can delete more features with large error to 
obtain a better estimation of camera motion
(but need to have more than 8)
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Setup Tracking Scene (1)

Press the ‘Setup Tracing Scene’ button
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Setup Tracking Scene (2)

Change to ‘3D Viewport’ 
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Setup Tracking Scene (3)

You will see Blender automatically create one plane 
(background) and one cube (foreground) for you
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Setup Tracking Scene (4)

1. Select Camera

2. Press ‘Overlay’ setting

3. Tick ‘Motion Tracking’

4. Enlarge the track vis. size

5. These are the estimated 3D 
location of our feature points
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Setup Tracking Scene (5)

You can switch between the ‘3D Viewport’ 
and ‘Movie Clip Editor’ for checking the 
positions of features
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Setup Tracking Scene (6)

1. Select 3 feature points (the plane of the scene)
It will map to the ‘Ground’ object (and receive shadows)

2. Press the ‘Floor’ button
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Setup Tracking Scene (7)

Go back to the ‘3D Viewport’, you will find the ‘Ground’ object 
has been aligned with the features you selected
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Setup Tracking Scene (8)

You can delete the default foreground box
(we will add our own foreground objects later)

Press the ‘Camera View’ button to see the composite
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Setup Tracking Scene (9)
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Setup Tracking Scene (10)

You can optionally select one feature point and 
press the ‘Set Origin’ button, the feature point 
will become the origin of the world space



110

Multimedia Techniques and Applications 2022

Setup Tracking Scene (11)

1. Select the ‘Ground’ object

2. Adjust its transform to 
better match your scene
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Setup Tracking Scene (12)

Drag the timeline to ensure the virtual plane matches the scene in each frame
(if it is, congratulations; if it is not, you need to modify your feature tracking)



Add Virtual 3D Models (and Animations)
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Add virtual 3D models and their animations

Use the techniques we taught to import 3D models and edit their animations
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Try to Render the Frame (1)

1. Switch to the ‘Render’ panel and change 
the renderer to ‘Cycle’ (ray-tracing)

2. Try to render the image for testing by 
selecting ‘Render’ ➔ ‘Render Image’
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Try to Render the Frame (2)

You will find your background image is missing
Let’s try to recover it !
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Try to Render the Frame (3)

In the ‘Render’ panel, tick ‘Transparent’
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Try to Render the Frame (4)

If you try to render the image again, 
you will find your background image is back!



Recap: Environment Lighting
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• Environment light illuminates the scene from a virtual 
sphere at infinite distance

• The spherical energy distribution is usually represented 
with longitude-latitude images

• Also called image-based lighting (IBL)



Recap: Environment Lighting
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• Widely used in digital visual effects and film production



Environment Lighting Resource
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• Download free HDR environment map on the internet
https://polyhaven.com/hdris

Choose one that matches your environment

https://polyhaven.com/hdris


Environment Lighting Resource (cont.)
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Choose resolution and file format
Since we only use it for smooth lighting, 
1K resolution is enough
(HDR format is suggested)
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Add more realistic lighting (1)

Switch to the ‘World’ panel 
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Add more realistic lighting (2)

Select ‘Environment Texture’
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Add more realistic lighting (3)

Select your downloaded image
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Add more realistic lighting (4)

The models are now shaded 
by the original light plus an 
environment map
You can adjust the strength of 
the environment lighting



Output Composite Video
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Set output configuration (1)

Switch to the ‘Output’ panel
Make sure the ‘Frame Rate’ 
matches your captured video
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Set output configuration (2)

Quick preview using Cycles (ray tracing) 
with fewer samples



129

Multimedia Techniques and Applications 2022

Render animation preview



130

Multimedia Techniques and Applications 2022

Preview (check the poses and animations of the models)
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Set to high-quality rendering

For a noise-free image, using at least 
512 – 1024 samples is suggested
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Final Output


